Monday, October 8, 2012

OM12 Installation Issue: (Additional) OM12 Management Server Won’t Install Because Of KB2677070

Wow! Thought had seen and tackled many installation issues. But this one really beats them all. That I cracked it and very fast as well isn’t because of me but because of my much respected colleague Henk Hoogendoorn, or better Mr ConfigMgr as I call him Glimlach.

So all credits for this posting go to him since he bumped into this issue some months ago and cracked it after some long hours… Thanks Henk!

When installing an (additional) OM12 Management Server all seems to go just fine. But when the OpsMgr DW database is being configured, it just goes wrong. The installation enters a loop which takes a long long time before it breaks. It hangs on the message Starting Services:

However, the System Center Data Access Service won’t start. Ever!

No matter what I tried, the additional OM12 Management Server wouldn’t install. Reboots, adding additional time to ServicesPipeTimeOut key, but no way.

(And Henk to the rescue Glimlach) As it turned out, this server had gotten al the Windows Updates, among them KB2677070. Henk mentioned to have bumped into this issue once before and after removing that particular update all just went fine…

I removed that update and rebooted the server.

Afterwards the installation of the additional OM12 Management Server went just fine!

So whenever you bump into installation issues when installing an (additional) OM12 Management Server make sure KB2677070 isn’t in place. When it is, REMOVE it and the installation of the (additional) OM12 Management Server will run smoothly.

Thanks again to Henk. Here is the blog posting he wrote about the same issue. And as stated before, this posting wouldn’t be here with out it!

No comments: